Debian logoDebian Screenshots >

needrestart

check which daemons need to be restarted after library upgrades

Daemons using outdated libraries
Daemons using outdated libraries
from version 2.11-4

Description

needrestart checks which daemons need to be restarted after library upgrades. It is inspired by checkrestart from the debian-goodies package.

Features:
 - supports (but does not require) systemd
 - binary blacklisting (i.e. display managers)
 - tries to detect required restarts of interpreter based daemons
   (supports Java, Perl, Python, Ruby)
 - tries to detect required resarts of containers (docker, LXC)
 - tries to detect pending kernel upgrades
 - could be used as nagios check_command
 - fully integrated into apt/dpkg using hooks

Upload more screenshots

Please help extend the collection of screenshots. Just make a screenshot and upload it here. You don't need to register or anything.


Homepage

https://github.com/liske/needrestart


Statistics

4757 other people were interested in this package here. The newest known version of this software is 2.11-4 (Information last updated about 10 hours ago.)