Debian logoDebian Screenshots >


framework to find and exploit web application vulnerabilities (CLI only)


w3af is a Web Application Attack and Audit Framework which aims to identify and exploit all web application vulnerabilities.

This package provides a command line interface (CLI) only. The graphical user interface (GUI) is provided by the package w3af.

The framework has been called the "metasploit for the web", but it's actually much more than that, because it also discovers the web application vulnerabilities using black-box scanning techniques!

The w3af core and it's plugins are fully written in Python. The project has more than 130 plugins, which identify and exploit SQL injection, cross site scripting (XSS), remote file inclusion and more.

Upload more screenshots

Please help extend the collection of screenshots. Just make a screenshot and upload it here. You don't need to register or anything.



233 other people were interested in this package here. The newest known version of this software is 1.6.54+git20160429-3 (Information last updated about 4 hours ago.)